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SETTING UP A NEW DATABASE FOR THE NEW TAX YEAR 
 
 

All pictures used in Help Docs are shown with the “Use In-Line (New Style Controls)” setting.  Your screens may differ. 
 
THIS DOCUMENT DOES NOT APPLY TO UNITS FOR WHOM BS&A DOES A 
YEARLY CONVERSION OF DATA FROM THE COUNTY 
 
 
 
STEP ONE:  ADD THE NEW DATABASE 
 

1. Open the File menu and select New Database. 

2. When you receive the Add a New Database window, type the name of your new database.  It should be 
no more than 8 characters long, with an optional 3-character extension (no spaces allowed).  For 
example:  MICH04 or MICHIGAN.04.  Press your [Enter] key or the Continue button when you are done 
typing. 

3. When you return to the Add a New Database window, click the Ok button. 

4. The program will create the new database and ask if you want to open it now.  Answer Yes. 
 
 
STEP TWO:  COPY INFORMATION FROM THE PREVIOUS YEAR DATABASE 
 
IMPORTANT.  There are two types of data files available for copying:  Database-specific and Parcel-
specific.  It is imperative you know the difference between the two and how each will affect your database. 
 
Database-specific files are the only files used in the process we are about to outline.  These files contain database-wide 
information such as Property Class Codes and School District Codes, but do not include which parcel gets what school code 
or which property class; basically, these files contain information that is available for use among all parcels.  A table 
illustrating the Database-specific files and whether or not you should consider copying them to your new database is 
provided below.  PLEASE REVIEW THIS TABLE PRIOR TO MAKING YOUR FILE SELECTIONS. 

 

Database-specific file Use 

TXBANK.DAT 
Contains ACH bank code information used when assigning a bank code to a parcel for ACH 
tax payments. 

TXGLEXP.DAT 
Contains your listing of General Ledger numbers for use with Equalizer and other GL 
programs.  GL setup information is found on the Taxes Setup window. 

TXMORT.DAT 

Contains your mortgage codes and mortgage company address information.  It will not 
assign mortgage codes to your parcels, nor will it copy the information from your previous 
year database.  See the help document entitled “Mortgage Code Transfer” available through 
the Help menu of the Tax System or on the FAQ page of this website.  Mortgage company 
setup information is found on the General Setup window. 

TXMSGS.DAT 
Contains your tax bill messages for Summer, Winter, and Village seasons.  Any specific date 
references will need to be updated once the previous year database is copied to the new 
database.  Tax Bill Message setup information is found on the General Setup window. 

TXNAMES.DAT 

Contains your tax names and millage rates tables.  Because the copy will copy prior years 
rates, DO NOT FORGET to update your millage rates in the new database BEFORE trying to 
balance your Roll.  Tax Names and Millage Rates Tables setup information is found on the 
Taxes Setup window. 
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TXPARAM.DAT 

Contains the settings for Program Preferences and Receipt Options from the previous year 
database, such as links to your Assessing System and/or Special Assessment System 
database(s) and your parcel number format.  DO NOT FORGET to update your link to the 
current year Assessing System database once you are in your new tax database.  Program 
Preferences setup information is found on the General Setup window; Receipt Options setup 
information is found on the Taxes Setup window. 

TXSPLIST.DAT 

Contains a list of your special assessment district codes and descriptions.  The codes per 
parcel will need to be added manually or imported from your prior year database. See the 
help document entitled “Transferring Special Assessments” available through the Help menu 
of the Tax System or on the FAQ page of this website.   Special Assessment setup 
information is found on the Taxes Setup window. 

TXUNIT.DAT 
Contains information about your unit such as your address information.  SPECIAL 
CONSIDERATIONS ARE INVOLVED IN COPYING THIS FILE.  PLEASE SEE “SPECIAL NOTE” AT 
THE END OF THIS SECTION (“STEP 2 – COPY INFORMATION…”) 

TXUSERD.DAT 
Contains user-specific settings for each database such as color preferences and field 
behavior.  User Preferences are found on the General Setup window. 

 
Parcel-specific files contain information about each individual parcel, such as the Taxable Value, any 
payments made to the parcel, legal descriptions, etc.  It is unlikely you would want to bring over payment 
information on a parcel from the previous year to the new year.  Parcel-specific files are not to be copied 
during this process. 
 
Determining which files to copy to your new database depends on your unit’s needs and how you use the Tax System.  
There may or may not be a need to copy particular files, and what works for one unit doesn’t necessarily work for another.  
IT IS UP TO YOU to decide which files illustrated above are best to copy from your previous year database to your new one.  
If after reviewing these files and their definitions you are unsure, please feel free to call us before attempting the copy 
process. 

 
1. While in your new database, open the File menu and select Copy Database. 

2. Click the Select Source (From) button and select your previous year database from the list that 
appears. 

3. Click the Select Target (To) button and select the database you just created. 

4. Your screen should resemble the picture, but keep in mind your database names will be different. 

Previous year database must appear in the Source box . 

New year database that you just created must appear in the Target box . 

Copy Options must say Copy Some Files . 

 



Equalizer Tax  HELP DOC 
 

www.bsasoftware.com  Ph 517.641.8900 / Fx 517.641.8960 Page 3 of 7 

5. Click the Select Files button to receive a list of the available files for copying. 

Press your [F1] key to bring up a Help window of the files available.  Each file is identified as either 
Database-specific or Parcel-specific. 

  

Database-specific files are the only files that will get copied to the new database.  DO NOT SELECT ANY 
“PARCEL-SPECIFIC” FILES.  If you feel you need to copy any Parcel-specific file(s), please call us before 
attempting the copy process. 

6. If you’ve opened the Help window, press your [Esc] key to close it. 

7. Double-click each Database-specific file (review the Table provided) you wish to copy from your 
previous year database to your new one.  This will move the file from the File List on the left to the Files 
Selected List on the right. 

When you have selected all files you want, this is how your screen may appear.  Keep in mind you are 
not required to copy all files shown; only those for your specific need. 

 

8. When you’re satisfied with your selection, click the Ok button to return to the Copy a Database window. 
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9. Click the Start Copy button.  You will receive a prompt warning you that the files you are copying will 
overwrite the data in the new database’s files.  Pay close attention to this warning and verify its 
accuracy; once you’ve verified that you are copying files to the new database, answer Yes to this 
prompt. 

10. When done, you will be told “Operation Complete”.  Click the Ok button to clear this message. 

 
SPECIAL NOTE:  IF YOU SELECTED “TXUNIT.DAT” AS ONE OF THE FILES TO BE COPIED, PLEASE 
FOLLOW THESE INSTRUCTIONS: 

 

11. Click Taxes Setup on the Navigation Tree. 

12. Click the Calculation Options button. 

13. Change the year appearing in the Tax Year field to the new tax year. 

14. Check the Summer, Winter, and Village Tax Bill Calculations fields.  Any of the three that read 
“Taxes read from Disk, No Auto Calc” need to be changed.  Click the  button at the edge of each field, 
answer Yes to the prompt, and select “Auto Calc (Round to the LOWEST cent)”. 

 

15. Click the Close button to return to the Taxes Setup window. 
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STEP THREE:  IMPORT FROM EQUALIZER ASSESSING 
 
Check with your assessor as to the location of the export files he/she created.  If both the Tax and Assessing 
Systems are on the same network, the assessor will most likely have put the export files directly on the 
network, eliminating the need for a diskette/CD/zip disk.  Use the following table as a guide for making the 
proper selections when prompted: 
 

 
 

1. If you were given a diskette/CD/zip disk, put it in the appropriate drive.  

2. Open the File menu and select Imports into Database. 

3. Select Various Imports to Communicate with Other Equalizer Software Systems. 

4. Select Equalizer Assessing/Equalization Import.  IF the Tax System detects a link to the 
Assessing/Equalization System, the following prompt appears.  In order to proceed, you must break the 
link; you will be able to re-establish the link by exiting the Tax System at the completion of the import.  
Answer Yes to remove the link. 

 

5. The program verifies that you wish to run the import (this prompt immediately appears if you were not 
linked to the Assessing/Equalization System).  Answer Yes. 

6. The program brings up a prompt verifying that you are in the correct database.  If you are, answer Yes. 

7. When asked if importing from a diskette or zip disk, answer appropriately depending on the location of 
the export files (use the table at the top of the page as your guide). 

8. If you are importing directly from a location on your network or hard drive, the Data Import window 
immediately appears.  If you are importing from a diskette/CD/zip disk, the export files will be copied to 
your program directory (typically, C:\EQTAXW); a prompt will appear when completed.  Answer Yes to 
this prompt to receive the Data Import window. 

Location of Export Files from Assessor When prompted if importing from disk or zip disk (Step 8)… 

Network or hard drive answer no and browse for location on network (or hard drive) 

Diskette answer yes and select (typically) A:\ 

CD or Zip Disk answer yes and browse for CDROM drive or Zip drive, whichever is used 
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9. Import Values, Import Names/Addresses, and Import Legals must be turned on* and the file names spelled 
as pictured . 

 
*If your taxes have been committed to disk, the fields in the Values file will not come in 
during the import; you will need to make any value changes through the Adjustment 
process.  The program will warn you if this is the case, and you will need to begin the 
import again, turning off the Import Values field. 

 
10. If you are importing directly from your network or hard drive, the Import Files… field reflects the 

location you specified in Step 8.  If you are importing from diskette/CD/zip disk, this field should read 
C:\EQTAXW . 

11. Leave the Update Existing Parcels Only field turned off . 

12. Check with your assessor as to which database was exported and make the appropriate selection in the 
Import Which Year Values field . 

13. Click the Choose Fields… button to receive a window where you can choose whether or not to import 
certain fields . 
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14. Among these fields is Mortgage Codes.  This is turned off -  - by default, meaning mortgage codes 
will not come in during the import.  If you would like to bring in mortgage codes from your Assessing 
program, click this field to turn it on - . 

 

15. Click the Close button in this window to return to the Data Import window. 

16. When you return to the Data Import window, click the Begin Import button and answer Yes when 
prompted. 

16. IMPORTANT REMINDERS:   

o modify your interest and penalty due dates   

o if you link to Equalizer Assessing, you will need to update this link to the assessor’s current 
database  

 
 

If you had been linked to the Assessing System, you will need to exit the Tax program and 
get back in to re-establish the link. 

 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Questions or concerns?  Please contact Tax Support at either 517.641.8900 or taxsupport@bsasoftware.com. 
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